All Forums

VARIABLE_STEP format

Hello everyone,

I just started working with swwm 5.1 and I'l already stuck... I try a very simple model to understand how the software works and I can't run anything at all.

Here is the example I'm working on (in fact it's simply the tutorial proposed by EPA)

model.png

When I try to compile it, I received the error message:

  ERROR 211: invalid number 0,80 at line 31 of [OPTION] section:  VARIABLE_STEP

However, no matter what I change in the option panel, I can't solve this error. It is said in the documentation that such an error is a wrong number format (negative number for instance).

As it is a by default value I just don't know what to do.

Does anyone has an idea how to proceed?

Thanks in advance,

Best,

Nicolas

You need to be a member of SWMM 5 or SWMM or EPASWMM - (not formally associated with EPA) to add comments!

Join SWMM 5 or SWMM or EPASWMM - (not formally associated with EPA)

Email me when people reply –

Replies

  • [STORAGE]
    ;;Name Elev. MaxDepth InitDepth Shape Curve Name/Params N/A Fevap Psi Ksat IMD
    ;;-------------- -------- ---------- ----------- ---------- ---------------------------- -------- -------- -------- --------
    Inlet 878 9 0 TABULAR StorageCurve 0 0

    Is your storage curve called Pond - 0    

    if it is then the problem  is the spaces

  • I'm having the same problem and tried all the suggested options. Still can't fix it?

    ERROR 211: invalid number - at line 74 of [STORAGE] section:
    Apond 1666 5 0 TABULAR Pond - 0

  • There is a fix for this issue in SWMM 5.1.003

    http://www.swmm5.net/2014/04/release-of-swmm-51003.html

  • I have the same problem and I'm not able to solve it.

    I have also modified dot and comma in the control panel but it doesn't work.

    Have you solved the problem? Thanks!

    • Yes, I solved de problem.

      I just followed the Robert's solution

      • So have you only changed the decimal mark from comma to dot in the control panel and it works? 

        Thanks again.

         

        • The problem is in the setting of Windows (not SWMM).
          I simply changed the commas with dot in Control Panels then convert all the commas in my file and that was it!

  • I have de same problem.

    How can I do to solve it?

    Thanks

    • Hi, This was the resolution to the previous problem

      Hello Robert,

      I found out my problem. Actually you suggested it by asking where I come from. The problem is in the setting of Windows (not SWMM).
      I simply changed the commas with dot in Control Panels then convert all the commas in my file and that was it!

      Thanks again.

      Nicolas

  • Hello Nicolas,
    I think you are actually using a value of 0,75 = change it to 0.75 with a decimal point.
    I hope this helps.
    Regards,
    Bob Dickinson 

This reply was deleted.