command line problem

Hello - I am trying to run SWMM5 (V21) from the command line but the model is not running as expected.  Upon command line execution, the SWMM GUI opens up and the command prompt opens displaying...

C:\swmmbat>epaswmm5.exe iter1.inp report.rpt output.out

(there is a space between the file names)

...but the model does not run.  If I run the .inp file directly from the GUI, the model runs just fine (suggesting no problems with the input file).  I've tried executing using several different methods (directly through command prompt, batch file and Matlab) but nothing works.


I have the epaswmm5.exe and swmm5.dll files located in the following folder along with the attached rainfall, input and batch files.  (apologies for the large rainfall file).



My batch file syntax is:

epaswmm5.exe iter1.inp report.rpt output.out

(yes, the batch file is located in the same folder as the .exe and .inp files and there are spaces inbetween file names)


My Matlab code is:

dos('epaswmm5.exe iter1.inp report.rpt output.out');

(NOTE: I've also tried the 'system' command..same results)


Thanks in advance for any suggestions you might offer.




You need to be a member of SWMM 5 or SWMM or EPASWMM - (not formally associated with EPA) to add comments!

Join SWMM 5 or SWMM or EPASWMM - (not formally associated with EPA)

Email me when people reply –


  • Hi,


    Instead of epaswmm5.exe iter1.inp report.rpt output.out


    it should be swmm5.exe  iter1.inp report.rpt output.out


    epaswmm5.exe is the GUI and SWMM5.exe is the dos command line executable


    Here is the dos version for SWMM 5.0.021

    • Ah ha.  That certainly was the problem.  Thanks so much for the quick reply, Robert.



This reply was deleted.