All Forums

"Edit Object" window won't open

Since yesterday my the "edit object" button won't open anymore. Also right click and chosing properties won't give information about the object. I have been working with SWMM for a few months now. I already tried to uninstall and install SWMM a few times. Can anyone give a suggestion on how to solve this problem?

You need to be a member of SWMM 5 or SWMM or EPASWMM - (not formally associated with EPA) to add comments!

Join SWMM 5 or SWMM or EPASWMM - (not formally associated with EPA)

Email me when people reply –

Replies

  • For me, the problem was that I had multiple displays hooked to my laptop at work, and I had last run SWMM5 on one of the external displays.  But when I ran at home with only the built-in display, SWMM5 still tried to display itself out in left field (where it was invisible).  The solution you found with the Alt+Space M worked for me, and I was able to pull the window back onto my main display.

    But later I discovered an even easier way.  With Windows 7 and higher, you can just press WIN+Shift and then left or right arrow once or twice to make the active window jump between displays.

  • Hi Robert. I think I managed to solve the problem. What I already thought was that the window was somewhere, but not visible to me. I figured that out when I tried to connect to VPN and also that window wouldn't open. I solved the problem this way:

    • 1.     Alt-tab to the SWMM window
    • 2.     Press Alt+Space.
    • 3.     Press M.
    • 4.     Press any Arrow key.
    • 5.     Move the mouse. The window position should now follow the mouse cursor.

    Sorry for bothering you with something that appeared not to be cause by the model, but by my computer. Though I hope these actions can help someone else suffering the same problem.

     

    Thanks a lot for your help though. It was really motivating to have someone thinking with you in an effective and quick way.

    Best,

    Anna

  • From the EPA i have this new suggestion

    "If you switched your display to a lower resolution (or maybe moved the Property Editor window on to a secondary monitor) the pixel coordinates of the Property Editor window may be off of the visible video screen. If that's the case you can try re-setting your video display to a higher resolution first. If that doesn't work then you can edit the file named "epaswmm5.ini" in your Users\<username>\AppData\Roaming\EPASWMM folder. Inside the file there's a section named [Property Editor]. You can try changing the Left and Top entries to 0,0 and see if that makes the editor window visible again. Or you can simply delete the file."

  • Let me ask around to see if there is any other solution.  Does Edit in the Menu work for you?

    20140908_0350.png

  • HI Robert. Even that I already tried and didn't work.. and yes I have the same problem with every file that I open.

  • Sorry for your continuing problems, Anna.  Can you try to delete the ini file associated with the inp file that you have having issues editing? Does your problem arise with every inp file, even the example inp file in your user folder?

    20140907_0828.png?width=721

  • I already tried compatibility mode for both windows 7 and windows XP, but still no difference.

  • One more suggestion: Try changing the compatibility of the program on your computer to Windows XP using properties since you use Windows 7

    20140904_2308.png

  • Also not.. I have that screen, but once I click on "Properties" nothing happens...

  • Hello Anna, can you at least right mouse click on the object in the plan view?20140902_1039.png

This reply was deleted.